$re = '/-(\w+)[= ](?|"((?:[^"\\\\]|\\\\.)*)"|(\d+))/';
$str = '-Parameter1=1234 -Parameter2=38518 -param3 "Test \\"escaped\\"" -param4 10 -param5 0 -param6 "TT" -param7 "Seven" -param8 "secret" "-SuperParam9=4857?--SuperParam10=123"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);