// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"-(\w+)[= ](?|"((?:[^"\\]|\\.)*)"|(\d+))"#).unwrap();
let string = "-Parameter1=1234 -Parameter2=38518 -param3 \"Test \\\"escaped\\\"\" -param4 10 -param5 0 -param6 \"TT\" -param7 \"Seven\" -param8 \"secret\" \"-SuperParam9=4857?--SuperParam10=123\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}