const regex = /-(\w+)[= ](?|"((?:[^"\\]|\\.)*)"|(\d+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(\\w+)[= ](?|"((?:[^"\\\\]|\\\\.)*)"|(\\d+))', 'g')
const str = `-Parameter1=1234 -Parameter2=38518 -param3 "Test \\"escaped\\"" -param4 10 -param5 0 -param6 "TT" -param7 "Seven" -param8 "secret" "-SuperParam9=4857?--SuperParam10=123"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}