$re = '/\d*\.\d*px/';
$str = '110px
0.2px
99.999999999px
56.25%
.4753729px
66.px';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);