using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(\d+)/?";
string input = @"https://www.dndbeyond.com/profile/Gadianton/characters/16837355
ddb.ac/characters/16837355/sfmp2b
https://www.dndbeyond.com/characters/16837355/sfmp2b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}