package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/(\d+)/?`)
var str = `https://www.dndbeyond.com/profile/Gadianton/characters/16837355
ddb.ac/characters/16837355/sfmp2b
https://www.dndbeyond.com/characters/16837355/sfmp2b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}