const regex = new RegExp('/(\\d+)/?', 'gm')
const str = `https://www.dndbeyond.com/profile/Gadianton/characters/16837355
ddb.ac/characters/16837355/sfmp2b
https://www.dndbeyond.com/characters/16837355/sfmp2b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}