#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)0[xX]([0-9a-fA-F]+)\nwtf"
Local $sString = "1616846098450" & @CRLF & _
"trying : 16633299966633299966633299" & @CRLF & _
"0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8" & @CRLF & _
"wtf" & @CRLF & _
"0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")