package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)0[xX]([0-9a-fA-F]+)\nwtf`)
var str = `1616846098450
trying : 16633299966633299966633299
0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8
wtf
0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}