# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"0[xX]([0-9a-fA-F]+)\nwtf"
test_str = ("1616846098450\n"
"trying : 16633299966633299966633299\n"
"0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8\n"
"wtf\n"
"0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.