// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)0[xX]([0-9a-fA-F]+)\nwtf").unwrap();
let string = "1616846098450
trying : 16633299966633299966633299
0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8
wtf
0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}