using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\w+#";
string substitution = @"func(\g<0>)";
string input = @"#symbol1# / 7 - #symbol2#";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}