$re = '/#\w+#/m';
$str = '#symbol1# / 7 - #symbol2#';
$subst = "func(\g<0>)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;