use strict;
my $str = '#symbol1# / 7 - #symbol2#';
my $regex = qr/#\w+#/mp;
my $subst = 'func(\\g<0>)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";