re = /#\w+#/m
str = '#symbol1# / 7 - #symbol2#'
subst = 'func(\\g<0>)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result