using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Иванов[\s,а,у,ым,е,ой,]{0,2}[\s]+А.*";
string input = @" 1.noant 2.vonrainman 3.YuriiKyiv 4.jbstudio 5.pitt56 6.Practice Makes Perfect 7.Dima_1st 8.daneel 9.ivanoff88 10.Eldram 11.serg_vn 12.sasha30 13.Chidori 14.iMrHyde ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}