re = /Иванов[\s,а,у,ым,е,ой,]{0,2}[\s]+А.*/m
str = ' 1.noant 2.vonrainman 3.YuriiKyiv 4.jbstudio 5.pitt56 6.Practice Makes Perfect 7.Dima_1st 8.daneel 9.ivanoff88 10.Eldram 11.serg_vn 12.sasha30 13.Chidori 14.iMrHyde '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end