use strict;
my $str = ' 1.noant 2.vonrainman 3.YuriiKyiv 4.jbstudio 5.pitt56 6.Practice Makes Perfect 7.Dima_1st 8.daneel 9.ivanoff88 10.Eldram 11.serg_vn 12.sasha30 13.Chidori 14.iMrHyde ';
my $regex = qr/Иванов[\s,а,у,ым,е,ой,]{0,2}[\s]+А.*/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}