package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Иванов[\s,а,у,ым,е,ой,]{0,2}[\s]+А.*`)
var str = ` 1.noant 2.vonrainman 3.YuriiKyiv 4.jbstudio 5.pitt56 6.Practice Makes Perfect 7.Dima_1st 8.daneel 9.ivanoff88 10.Eldram 11.serg_vn 12.sasha30 13.Chidori 14.iMrHyde `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}