#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^а-яА-ЯёЁ\w]|^)[а-яА-ЯёЁa-zA-Z,-]{1,4}(?=[^а-яА-ЯёЁ\w]|$)"
Local $sString = "Благовещенский р-н, Степное Озеро рп, Попова ул, 14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")