re = /(?:[^а-яА-ЯёЁ\w]|^)[а-яА-ЯёЁa-zA-Z,-]{1,4}(?=[^а-яА-ЯёЁ\w]|$)/m
str = 'Благовещенский р-н, Степное Озеро рп, Попова ул, 14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end