using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^а-яА-ЯёЁ\w]|^)[а-яА-ЯёЁa-zA-Z,-]{1,4}(?=[^а-яА-ЯёЁ\w]|$)";
string input = @"Благовещенский р-н, Степное Озеро рп, Попова ул, 14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}