$re = '/(?:[^а-яА-ЯёЁ\w]|^)[а-яА-ЯёЁa-zA-Z,-]{1,4}(?=[^а-яА-ЯёЁ\w]|$)/m';
$str = 'Благовещенский р-н, Степное Озеро рп, Попова ул, 14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);