#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\wÀ-ú ]+ - ){2}[\wÀ-ú]+$"
Local $sString = "abc - xyz - 123" & @CRLF & _
"abc - xyz - 123 - a" & @CRLF & _
"- - - - -" & @CRLF & _
"_ - ____ - _"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")