package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\wÀ-ú ]+ - ){2}[\wÀ-ú]+$`)
var str = `abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}