import re
regex = re.compile(r"^([\wÀ-ú ]+ - ){2}[\wÀ-ú]+$", flags=re.MULTILINE)
test_str = ("abc - xyz - 123\n"
"abc - xyz - 123 - a\n"
"- - - - -\n"
"_ - ____ - _")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")