using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<tag +([abc])=“([xyz])“ +(?!\1)([abc])=“(?!\2)([xyz])“ +(?!\1|\3)[abc]=“(?!\2|\4)[xyz]“\/>$";
string input = @"<tag a=“x“ c=“y“ b=“z“/>
<tag c=“x“ b=“y“ a=“z“/>
<tag a=“x“ b=“y“ c=“x“/>
<tag a=“x“ b=“y“ a=“x“ c=“z“/>
<tag a=""x“ b=“y“/>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}