const regex = new RegExp('^<tag +([abc])=“([xyz])“ +(?!\\1)([abc])=“(?!\\2)([xyz])“ +(?!\\1|\\3)[abc]=“(?!\\2|\\4)[xyz]“\\/>$', 'gm')
const str = `<tag a=“x“ c=“y“ b=“z“/>
<tag c=“x“ b=“y“ a=“z“/>
<tag a=“x“ b=“y“ c=“x“/>
<tag a=“x“ b=“y“ a=“x“ c=“z“/>
<tag a="x“ b=“y“/>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}