$re = '/^<tag +([abc])=“([xyz])“ +(?!\1)([abc])=“(?!\2)([xyz])“ +(?!\1|\3)[abc]=“(?!\2|\4)[xyz]“\/>$/m';
$str = '<tag a=“x“ c=“y“ b=“z“/>
<tag c=“x“ b=“y“ a=“z“/>
<tag a=“x“ b=“y“ c=“x“/>
<tag a=“x“ b=“y“ a=“x“ c=“z“/>
<tag a="x“ b=“y“/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);