use strict;
my $str = '<tag a=“x“ c=“y“ b=“z“/>
<tag c=“x“ b=“y“ a=“z“/>
<tag a=“x“ b=“y“ c=“x“/>
<tag a=“x“ b=“y“ a=“x“ c=“z“/>
<tag a="x“ b=“y“/>
';
my $regex = qr/^<tag +([abc])=“([xyz])“ +(?!\1)([abc])=“(?!\2)([xyz])“ +(?!\1|\3)[abc]=“(?!\2|\4)[xyz]“\/>$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}