#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d|\b([a-zA-Z])"
Local $sString = "1234 Something another thing" & @CRLF & _
"569 Camel case is Important" & @CRLF & _
"123&else" & @CRLF & _
"A word here and numbers 1234" & @CRLF & _
"Someone 0987 and string"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")