const regex = /\d|\b([a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d|\\b([a-zA-Z])', 'gm')
const str = `1234 Something another thing
569 Camel case is Important
123&else
A word here and numbers 1234
Someone 0987 and string`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}