// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d|\b([a-zA-Z])").unwrap();
let string = "1234 Something another thing
569 Camel case is Important
123&else
A word here and numbers 1234
Someone 0987 and string";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}