package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d|\b([a-zA-Z])`)
var str = `1234 Something another thing
569 Camel case is Important
123&else
A word here and numbers 1234
Someone 0987 and string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}