package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?i)lt[\s]*[\d]+`)
var str = `lt34 xvfgdfgd
LT 34 xvfgdfgd
aa lT 1354k xv33 fgdfgd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}