// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?i)lt[\s]*[\d]+").unwrap();
let string = "lt34 xvfgdfgd
LT 34 xvfgdfgd
aa lT 1354k xv33 fgdfgd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}