$re = '/(?i)lt[\s]*[\d]+/i';
$str = 'lt34 xvfgdfgd
LT 34 xvfgdfgd
aa lT 1354k xv33 fgdfgd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);