re = /(?i)lt[\s]*[\d]+/i
str = 'lt34 xvfgdfgd
LT 34 xvfgdfgd
aa lT 1354k xv33 fgdfgd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end