#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^\d]|^)(\d)([^\w]|\..+|$)"
Local $sString = "файл1.ssdf" & @CRLF & _
"файл22.sdf" & @CRLF & _
"файл1-часть02.asd" & @CRLF & _
"sdfsd01" & @CRLF & _
"sdfsdf11-sdfsd7" & @CRLF & _
"sfdsd1sdfsdsdf003"
Local $sSubst = "$10$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)