use strict;
my $str = 'файл1.ssdf
файл22.sdf
файл1-часть02.asd
sdfsd01
sdfsdf11-sdfsd7
sfdsd1sdfsdsdf003';
my $regex = qr/([^\d]|^)(\d)([^\w]|\..+|$)/mp;
my $subst = '$10$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";