$re = '/([^\d]|^)(\d)([^\w]|\..+|$)/m';
$str = 'файл1.ssdf
файл22.sdf
файл1-часть02.asd
sdfsd01
sdfsdf11-sdfsd7
sfdsd1sdfsdsdf003';
$subst = "$10$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;