// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\d]|^)(\d)([^\w]|\..+|$)").unwrap();
let string = "файл1.ssdf
файл22.sdf
файл1-часть02.asd
sdfsd01
sdfsdf11-sdfsd7
sfdsd1sdfsdsdf003";
let substitution = "$10$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}