$re = '/[-+]?(?:\d+[\d,]*)?\.?\d+/';
$str = '7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);