re = /[-+]?(?:\d+[\d,]*)?\.?\d+/
str = '7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end