import re
regex = re.compile(r"[-+]?(?:\d+[\d,]*)?\.?\d+")
test_str = "7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")