using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])(?!\1)([a-z])\2\1(?![^[]*])";
string input = @"baab[pqrs]asdf yes boobs
abcd[pqqp]xzzx no ..cc.
bbbb[zxcv]bnmkop no
adad ddss sdds ssssdds
ixooxj[kjhgfd]mnbvcxz yes
iubduyyr[exauibqlf]ytrddstz no
extoxp[bylubaahxfxiesk]brpqqpbo yes
axxa
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}