import Foundation
let pattern = #"([a-z])(?!\1)([a-z])\2\1(?![^[]*])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
baab[pqrs]asdf yes boobs
abcd[pqqp]xzzx no ..cc.
bbbb[zxcv]bnmkop no
adad ddss sdds ssssdds
ixooxj[kjhgfd]mnbvcxz yes
iubduyyr[exauibqlf]ytrddstz no
extoxp[bylubaahxfxiesk]brpqqpbo yes
axxa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)