use strict;
my $str = 'baab[pqrs]asdf yes boobs
abcd[pqqp]xzzx no ..cc.
bbbb[zxcv]bnmkop no
adad ddss sdds ssssdds
ixooxj[kjhgfd]mnbvcxz yes
iubduyyr[exauibqlf]ytrddstz no
extoxp[bylubaahxfxiesk]brpqqpbo yes
axxa
';
my $regex = qr/([a-z])(?!\1)([a-z])\2\1(?![^[]*])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}