re = /([a-z])(?!\1)([a-z])\2\1(?![^[]*])/
str = 'baab[pqrs]asdf yes boobs
abcd[pqqp]xzzx no ..cc.
bbbb[zxcv]bnmkop no
adad ddss sdds ssssdds
ixooxj[kjhgfd]mnbvcxz yes
iubduyyr[exauibqlf]ytrddstz no
extoxp[bylubaahxfxiesk]brpqqpbo yes
axxa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end