#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\[)([a-z])(?!\1)([a-z])\2\1(?!])"
Local $sString = "baab[pqrs]asdf yes boobs" & @CRLF & _
"abcd[pqqp]xzzx no ..cc." & @CRLF & _
"bbbb[zxcv]bnmkop no" & @CRLF & _
"adad ddss sdds ssssdds" & @CRLF & _
"ixooxj[kjhgfd]mnbvcxz yes" & @CRLF & _
"iubduyyr[exauibqlf]ytrddstz no" & @CRLF & _
"extoxp[bylubaahxfxiesk]brpqqpbo yes" & @CRLF & _
"" & @CRLF & _
"[axxa" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")